The Troll's factory

Geekeries & pensées
-->

SVN sous Eclipse avec Subclipse : « Unable to load default SVN client » toi-même ! // Eclipse and SVN with Subclipse

For English Readers, see the English version of the article at the bottom of the French one.

 

Un autre micro-billet pour signaler à tous ceux qui sont en train de s’arracher les cheveux en essayant de faire fonctionner sur très intéressant / pratique (néanmoins difficile à installer !) plug-in « Subclipse » pour Eclipse et SVNque la solution est ailleurs !

 

Ailleurs dans le sens où il ne faut pas chercher à résoudre le souci, il faut tout bonnement ne pas utiliser la dernière version de Subclipse (branche 1.8.x) mais la version 1.4.8 (branche 1.4.x).

 

Donc si on reprend l’installation de Subclipse en rapide, ça donne :

  1. Lancer Eclipse
  2. Menu Help > Install New Software
  3. Dans la barre de « sites » en haut, cliquer sur « Add« , en URL mettez : http://subclipse.tigris.org/update_1.4.x (mettez ce que vous voulez pour le nom)
  4. Sélectionner ce site-là dans la liste
  5. Environs 8 plug-ins apparaissent, cochez les tous. Sauf celui qui s’appelle « Intégration avec Mylyn 3″ (ou un truc très très très ressemblant).
  6. Faites Next, etc. … ensuite, vous suivez les indications.

 

Personnellement, il a aussi fallu que je décoche le paquet  « SVN Revision Graph ». Qui avait un souci de dépendance paraitrait-il… (je m’en sers pas de toutes façons donc….). Donc si vous avez un souci pour l’installation, regardez les messages d’erreurs et tentez de décocher SVN Revision Graph :) .

 

 

——————————— English version ——————————

 

Another micro-article to make available on the internet a useful information for those who are currently desperate at install Subclipse for Eclipse to use with SVN : solution is not where you think it should be !

What does that mean ? This means don’t try to troubleshoot by repairing libraries or things like that … No, just don’t use the latest (1.8.x branch) version of Subclipse : Use the 1.4.8 (1.4.x branch) !

 

So, installation process from A to Z should be (sum-up) :

  1. Launch Eclipse
  2. Menu Help > Install New Software
  3. In the « sites » select menu at the top, click on « Add« , in URL put : http://subclipse.tigris.org/update_1.4.x (and put what you want for the name)
  4. Select this precise « site » in the select list.
  5. About 8 plug-ins are appearing, check them all. Except the one called « Integration with Mylyn 3″ (or some name very similar).
  6. Press Next, etc. …then, just follow the directives.

 

For my experience : I also had to uncheck the « SVN Revision Graph » package. Its seemed to have some dependencies issues… (I don’t use it so…). So if you can any trouble for installing the 7 other packages, try to uncheck « SVN Revision Graph », it may do the trick.

Share and Enjoy:
  • Print
  • PDF
  • Twitter
  • Facebook
  • LinkedIn
  • RSS
  • Wikio FR
  • Digg
  • del.icio.us
  • Google Bookmarks
  • Technorati
  • Sphinn
  • Mixx
  • Add to favorites
  • Live
  • Netvibes
  • Scoopeo
  • viadeo FR
  • Identi.ca
  • MySpace
  • StumbleUpon
  • Yahoo! Buzz
posté par Troll dans Non classé avec aucun commentaire

Poster un commentaire

Remplissez le formulaire suivant pour poster un message.
Nom
Email
Site internet
Votre commentaire